Netbeans 7.1.1 & Subversion 1.19.* import werkt niet

Netbeans en subversion gaan soms niet echt vloeiend samen en zo nu en dan kost het je best wat tijd om dingen weer ‘recht’ te trekken maar vandaag maakten ze het wel heel bont. Het begon met een project waar de SVN dusdanig verziekt was dat ik het verstandiger vond om deze even opnieuw te builden. Simpel; oude repo weggegooid, .svn folders opgeruimd en Netbeans opnieuw gestart om te wennen aan de nieuwe situatie. Maar om onduidelijke redenen wilde hij gewoon niet meer opnieuw het project importeren in SVN. Wat ik ook deed, na Team > Subversion > Import into repository bleef alles stil, geen errors, geen meldingen, helemaal niets… Halve internet doorzocht, logs doorgespit maar gewoon null.

Had al bijna besloten dat dit project op zich geen SVN nodig had maar wilde gewoon niet toegeven aan een overwinning van Netbeans & Subversion dus toen toch nogmaals alles rustig bekeken. Enige wat ik kon bedenken was dat hij toch ergens in een soort cache herinneringen had die hem dwars zaten. Wat was geen oplossing;

  1. NBproject data van project verwijderen
  2. Netbeans 100x opnieuw opstarten
  3. PC opnieuw opstarten
  4. Netbeans updates installeren (stonden er nog paar klaar)
  5. Log files lezen

Uiteindelijk besloten om alle SVN cache van Netbeans te vernietigen (windows 7 te vinden in C:\Users\[username]\.netbeans\7.1\var\cache\svncache) en dit loste het probleem op wonderbaarlijke wijze op. Moet me er voor nu bij neerleggen dat niet snappen maar gewoon erop inhakken door cache te legen de enige oplossing was die werkte. Had nog wel wat mensen met soortgelijke problemen gezien maar toch nét niet hetzelfde.

Geef een reactie

Jouw e-mailadres wordt niet gepubliceerd. Verplichte velden zijn gemarkeerd met *